Forum Officiel d'AlloForum
Forum Officiel d'AlloForum
Administrateurs : Yack
 
 Forum Officiel d'AlloForum  Probleme Technique ou bugs 

 [FIN] Catégorie protégée par mot de passe

Nouveau sujet   Répondre
 
Bas de pagePages : 1  
Abraxas
GroDemon - 200% optimiste
Moderateur AlloForum
Abraxas
200 messages postés
   Posté le 27-10-2006 à 13:33:40   Voir le profil de Abraxas (Offline)   Répondre à ce message   http://abrasax.alloforum.com/   Envoyer un message privé à Abraxas   

Bonjour,

Aujourd'hui j'ai essayé de rajouter un mot de passe sur une des catégorie du forum, mais pour une raison inconnu après avoir entré le mot de passe je recois d'abord un message "mot de passe valide" puis un autre tout de suite après "catégorie à accès restreint".... et je me retrouve devant l'index du forum...

J'ai déjà créer des catégories à accès restreint par mot de passe sans problème, la diffèrence c'est qu'au lieu d'avoir le lien :

http://abrasax.alloforum.com/liste_sujets-11765-0-2199-0-0-1.html

comme pour toute les catégories (incluant les catégories à accès restreint pas mot de passe) j'ai maintenant un lien de type

http://abrasax.alloforum.com/mdp.php?groupe=0&categorie=2199

Quelqu'un a une idée, d'où ca pourrait venir ?

Grüß

Abra
helimidade
Bonne amitié est seconde parenté
Moderatrice AlloForum
helimidade
1944 messages postés
   Posté le 27-10-2006 à 14:12:14   Voir le profil de helimidade (Offline)   Répondre à ce message   Envoyer un message privé à helimidade   

Bonjour

A tout hasard: le groupe de cette catégorie ne serait-il pas déjà restreint par level

c'est juste une suggestion


--------------------


mon petit blog sans prétention: http://edadimileh.canalblog.com/
Abraxas
GroDemon - 200% optimiste
Moderateur AlloForum
Abraxas
200 messages postés
   Posté le 27-10-2006 à 14:36:30   Voir le profil de Abraxas (Offline)   Répondre à ce message   http://abrasax.alloforum.com/   Envoyer un message privé à Abraxas   

Bonjour,

Merci pour cette réponse rapide.

Le groupe ne contient aucune restriction, d'ailleur je ne savais pas qu'on pouvait mettre une restriction sur un groupe entier...

Au départ cette catégorie était restreint par level, avec la multiplication des membres, nous avons décidé de restreindre cette catégorie par une mot de passe.

Dans les options d'administration j'ai donc selectionné l'accès restreint par "mot de passe" et c'est une option box, ce qui veut dire qu'on ne peut pas avoir les deux en même temps.... (sauf si on selectionne l'accès restreint par level, et la lecture par mot de passe ce qui n'est pas mon cas...)

Dans le doute, j'ai quand même enlevé toute forme de restriction, puis remis le mot de passe avec le même effet...

Grüß

Abra

--------------------
Carita bene ordonata incipit a se met ipso
http://abrasax.alloforum.com/
helimidade
Bonne amitié est seconde parenté
Moderatrice AlloForum
helimidade
1944 messages postés
   Posté le 27-10-2006 à 14:51:25   Voir le profil de helimidade (Offline)   Répondre à ce message   Envoyer un message privé à helimidade   

Abraxas a écrit :


Le groupe ne contient aucune restriction, d'ailleur je ne savais pas qu'on pouvait mettre une restriction sur un groupe entier...


On peut le faire, tout comme pour les catégories; sauf que pour le groupe il faut l'editer pour changer les restrictions...

Je suis désolée de n'avoir pas pu t'aider

Bon week-end


--------------------


mon petit blog sans prétention: http://edadimileh.canalblog.com/
Yack
Administrateur
Yack
2481 messages postés
   Posté le 03-11-2006 à 13:05:56   Voir le profil de Yack (Offline)   Répondre à ce message   Envoyer un message privé à Yack   

Bonjour,

Dans ta zone d'administration, édite le groupe et mets en "Accès non restreint".

Ensuite édite la catégorie concernée, et fais de même en la mettant en "Accès non restreint".

Vérifie si cela fonctionne.

Si tel est le cas, retourne en zone d'administration, édite la catégorie et mets l'accès restreint que tu souhaitais mettre en place.

Attention, durant toutes ces manipulations, n'oublie pas de bien actualiser la page d'accueil de ton forum, afin que les changements de liens soit bien visibles.

Bonne journée,
A+
Abraxas
GroDemon - 200% optimiste
Moderateur AlloForum
Abraxas
200 messages postés
   Posté le 03-11-2006 à 13:19:55   Voir le profil de Abraxas (Offline)   Répondre à ce message   http://abrasax.alloforum.com/   Envoyer un message privé à Abraxas   

Bonjour,

je viens de le faire et j'ai toujours le même problème, j'ai enlevé toute les restriction d'accès du groupe, j'ai réactualiser et pas de problème. J'ai enlevé la restriction d'accès de la catégorie... toujours pas de problème...

Ensuite j'ai rajouté mon mot de passe, je me connecte à la catégorie et il me demande mon mot de passe... une fenêtre s'affiche "mot de passe valide" et puis tout de suite apprès "catégorie à accès restreint"... J'en perd mon latin....

Le mot de passe ne comprend pas de caractère spéciaux, et je ne suis pas le seul membre de mon forum à avoir ce problème... J'ai vidé le cache et je ne bloque aucun cookie...

Mystère.... peut-être un aimable membre de ce forum pourrait-il faire le test sur son forum, pour voir si le problème est "général" où bien si c'est moi qui sent le patée...

Merci pour ta réponse Yack...

Grüß

Abra
Yack
Administrateur
Yack
2481 messages postés
   Posté le 14-11-2006 à 00:25:46   Voir le profil de Yack (Offline)   Répondre à ce message   Envoyer un message privé à Yack   

Bonsoir,

Tu sembles avoir résolu le problème ?

A+
Abraxas
GroDemon - 200% optimiste
Moderateur AlloForum
Abraxas
200 messages postés
   Posté le 14-11-2006 à 10:50:01   Voir le profil de Abraxas (Offline)   Répondre à ce message   http://abrasax.alloforum.com/   Envoyer un message privé à Abraxas   

Bonjour,

Et bien j'ai supprimé le mot de passe et rajouté une restriction par level (qui marche)...

Ce n'est pas vraiment une résolution du problème, puisqu'il m'est toujours impossible d'accéder au nouvelles catégories que je veux protéger par un mot de passe.

Donc pour l'instant il m'est impossible de créer une catégorie protéger par mot de passe, que ce soit moi ou les membres, la réponse est invariablement la même, mot de passe correct, puis juste après "catégorie à accès restreint"...

Ce qui serait bien c'est de savoir si ce genre de problème apparait sur d'autre forum.

En attendant j'ai mis une restriction par level, mais honnêtement je préfererai un mot de passe.

Grüß

Abra


--------------------
Carita bene ordonata incipit a se met ipso
http://abrasax.alloforum.com/
Membre désinscrit
   Posté le 15-11-2006 à 21:52:59   

J'ai créer une catégorie à mot de passe récemment et je n'ai aucun problème avec.
Abraxas
GroDemon - 200% optimiste
Moderateur AlloForum
Abraxas
200 messages postés
   Posté le 15-11-2006 à 23:27:14   Voir le profil de Abraxas (Offline)   Répondre à ce message   http://abrasax.alloforum.com/   Envoyer un message privé à Abraxas   

Bonjour,

Après avoir lu ta réponse coccinel, j'ai voulu en avoir le coeur net, j'ai donc créer un nouveau groupe, créer une nouvelle catégorie, et mis un mot de passe... et là surprise... tout marche bien...

je recommence avec les sections que je voulais mettre en restriction, et toujours le même problème...

Mais j'ai trouvé le problème...

Pour une raison inconnu, après avoir enlevé le mot de passe, si je veux le remettre, je ne peux pas utiliser le même mot... Il faut que j'utilise un nouveau mot.. et là tout remarche...

Donc pour moi j'ai changé les mots de passes, et tout re-marche...

Merci à toi coccinel, pour avoir confirmé que c'étais bien moi qui sentait le patée et pas le service d'alloforum...

Grüß

Abra

EDIT: après un nouveau test je corrige encore ce que j'ai dit... L'erreur vient du fait que j'avais mis une majuscule dans le mot de passe... sans majuscule tout marche bien...

Donc tout est de ma fautes, mea culpa je suis trop bête....

Message édité le 15-11-2006 à 23:46:27 par Abraxas


--------------------
Carita bene ordonata incipit a se met ipso
http://abrasax.alloforum.com/
Yack
Administrateur
Yack
2481 messages postés
   Posté le 25-11-2006 à 14:06:15   Voir le profil de Yack (Offline)   Répondre à ce message   Envoyer un message privé à Yack   

Bonjour,

Pas de problème et merci de nous avoir tenu informés, tout fonctionne et c'est le principal

Bon WE,
A+
Haut de pagePages : 1  
 
 Forum Officiel d'AlloForum  Probleme Technique ou bugs  [FIN] Catégorie protégée par mot de passeNouveau sujet   Répondre
 
Identification rapide :         
 
Divers
Imprimer ce sujet
Aller à :   
 
créer forum